Forum Polskiego Kursu Blendera

Kurs Blendera dla wszystkich Polaków!

Brak synchronizacji - pytania początkującego

Autor Wątek: Brak synchronizacji - pytania początkującego  (Przeczytany 1017 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline torero

  • Nowy użytkownik
  • *
  • Wiadomości: 9
  • Reputacja +0/-0
  • jestem tu nowy!
    • Zobacz profil
Brak synchronizacji - pytania początkującego
« dnia: 20160504, 21:39:13 »
Witam wszystkich serdecznie z głębi rozpaczy,

grafik ze mnie żodyn, amatorsko kręcę tylko rodzinne filmy archiwalne i od dawna chcę zmienić Movie Studio na Blendera, bo po pierwsze do tej grafiki i efektów jednak człowieka ciągnie [od czegoś trzeba zacząć], a po drugie nie chce mi się już za każdym razem przełączać na windowsa, kiedy potrzebuję zmontować jakiś dokument [działam głównie na linuksie]. I tutaj jest problem...

Film kręcony Sony a77 @ 50 fps [plik MTS], importowany do blendera [2.69 na ubuntu, jeśli to ma jakiekolwiek znaczenie]. Brak synchronizacji audio-video, ścieżka audio wizualnie w VSE dwa razy dłuższa. Z tym sobie radzę, zmieniam 24 fps na 50 fps i ścieżka video przykrawa się do audio znacznie lepiej... ale niestety nie perfekcyjnie. Na 15-sekundowym klipie rozjazd pomiędzy audio a video wynosi [wizualnie, patrząc organoleptycznie po długości ścieżek] jakieś 0.01 sek, dłuższych klipów nawet nie sprawdzam.

Co robię źle? AV-sync włączone, ale nawet wyłączenie nie powoduje żadnej widocznej zmiany. Proszę o pomoc, bo walenie głową w ścianę na samiutkim początku planowanej migracji jest mocno demotywujące...

I drugie pytanie, z lekkim wyprzedzeniem. Czy istnieje jakikolwiek zestaw presetów do renderingu, dzięki któremu film da się otworzyć na "zwykłej" Bravii? Przy odtwarzaniu wygenerowanych dotychczas filmów "asynchronicznych" mój telewizor wszczyna awantury o brak jakichś kodeków?

Offline torero

  • Nowy użytkownik
  • *
  • Wiadomości: 9
  • Reputacja +0/-0
  • jestem tu nowy!
    • Zobacz profil
Odp: Brak synchronizacji - pytania początkującego
« Odpowiedź #1 dnia: 20160504, 21:52:23 »
Sam sobie: o ile dobrze czytam z ekranu, różnica wynosi jedną klatkę [793 "klatki" audio, 792 video]. Tyle, że nijak nie przybliża mnie to do rozwiązania problemu... :/

Offline Kamil1064

  • Ekspert
  • *
  • Wiadomości: 3845
  • Reputacja +164/-1
  • Płeć: Mężczyzna
    • Zobacz profil
Odp: Brak synchronizacji - pytania początkującego
« Odpowiedź #2 dnia: 20160504, 21:54:20 »
Witaj w PKB :)
Sprawdź na swoim sprzęcie (np. google) w ilu FPS-ach Twoja kamerka naprawdę nagrywa, raz miałem taką sytuację, że było to 23.98. Przy dłuższym filmie są rozjazdy.
Nie ważne ile razy upadłeś, ważne ile razy się podniosłeś.

Offline torero

  • Nowy użytkownik
  • *
  • Wiadomości: 9
  • Reputacja +0/-0
  • jestem tu nowy!
    • Zobacz profil
Odp: Brak synchronizacji - pytania początkującego
« Odpowiedź #3 dnia: 20160505, 10:55:34 »
No dobrze, jakoś udało mi się to opanować... przy "custom FR", manipulując framerate base metodą prób i błędów do wielkości 1.028 bodajże udało mi się to wyrównać. Dla odmiany nagranie w MP4 zachowuje się poprawnie i proste przestawienie na 25 fps nie wykazuje odchyleń. Ale... serio trzeba ustawiać fps ręcznie i oddzielnie dla każdego ujęcia?

Offline Zygfryd

  • Aktywny użytkownik
  • *
  • Wiadomości: 354
  • Reputacja +31/-1
  • Płeć: Mężczyzna
  • eeee mmmm yyyy
    • Zobacz profil
Odp: Brak synchronizacji - pytania początkującego
« Odpowiedź #4 dnia: 20160505, 12:40:12 »
Jeżeli możesz, to zainstaluj sobie najnowszego blendera. Ten automatycznie dopasowuje fps do pierwszego wczytanego filmu.

Offline torero

  • Nowy użytkownik
  • *
  • Wiadomości: 9
  • Reputacja +0/-0
  • jestem tu nowy!
    • Zobacz profil
Odp: Brak synchronizacji - pytania początkującego
« Odpowiedź #5 dnia: 20160506, 22:52:35 »
Dzięki wszystkim za pomoc. Nowy blender zainstalowany, problem o dziwo ustąpił, w to miejsce wskoczyły inne. Dopiero niedawno doczytałem, że blender samodzielnie nie potrafi przeprowadzić interpolacji klatek [czy jak to się tłumaczy na polski] w projekcie z klipami o różnym klatkażu [w Movie Studio najzwyczajniej nie zawracałem sobie tym głowy], i już drugi dzień próbuję znaleźć jakieś narzędzie pod lin. avxsynth nie daje się skompilować i co rusz wyrzuca błędy, a vapoursyntha udało mi się [teoretycznie] zainstalować, ale na razie nie wgryzłem się jeszcze w dokumentację. Ciężka droga przede mną...

Offline torero

  • Nowy użytkownik
  • *
  • Wiadomości: 9
  • Reputacja +0/-0
  • jestem tu nowy!
    • Zobacz profil
Odp: Brak synchronizacji - pytania początkującego
« Odpowiedź #6 dnia: 20160507, 15:09:20 »
Sam sobie jeszcze raz, może komuś się przyda: wszystko powyżej - historie z dodatkowymi aplikacjami, samodzielna kompilacja itp. - to ślepa uliczka, wystarczyło zainstalować Blender Velvets i wszystko gra. Level zaliczony ;)

Offline klaratt

  • Przybysz
  • *
  • Wiadomości: 1
  • Reputacja +0/-0
  • jestem tu nowy!
    • Zobacz profil
Odp: Brak synchronizacji - pytania początkującego
« Odpowiedź #7 dnia: 20170302, 20:49:37 »
czesc

Tags:
 

© Polski Kurs Blendera, CC-BY, 2014