Forum Polskiego Kursu Blendera

Kurs Blendera dla wszystkich Polaków!

Blender nie renderuje wszystkiego

Autor Wątek: Blender nie renderuje wszystkiego  (Przeczytany 1888 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline A.S.

  • Użytkownik
  • *
  • Wiadomości: 70
  • Reputacja +0/-0
  • Płeć: Mężczyzna
    • Zobacz profil
Blender nie renderuje wszystkiego
« dnia: 20160505, 15:41:24 »
Dzień dobry. Od dłuższego czasu pracuję w Blenderze nad pewną animacją,  Sam program poraz pierwszy uruchomiłem dopiero kilka miesięcy temu, więc nie znam się na nim zbyt dobrze.

Dzisiaj pojawił mi się kolejny, tym razem dziwny problem.
Mam scenę w Blenderze. Jednak jeden element dodany do niej w Video Editing wymagał bym tło do animacji umieścił w osobnej scenie. Ta pierwsza zaś ma tło przezroczyste. Następnie w VSE dodałem obie sceny jedną nałożoną na drugą. Oprócz tego jest jeszcze animowany płomień 2d zrobiony w GIMP-ie (w Blenderze płomień mi wyjść nie chciał).

Animację renderuje częściami. Wszystko szło dobrze aż do dzisiaj. Po całonocnej pracy ,  Blender wyrenderował mi klatki bez tła ze sc. 2. oraz bez tego ognia, a także bez efektu rozjaśnienia które dodałem do sceny nr. 1.

Klatka 1004 jest jeszcze dobra a klatka 1005 już nie.

Sprawdziłem także wybrane klatki wcześniejsze. Mimo że przedtem były dobre teraz renderują mi się z przezroczystością zamiast tła.

Patrzyłem także w edytorze animacji czy nie mam czegoś niepotrzebnie zakluczowane ale na klatkach 1004-1005 jest jedna wielka pustka.

Czy jest jakiś sposób żeby coś na to poradzić?

Bo jeżeli nie to mogę jeszcze zapisać oddzielnie resztę sc.1 i sc 2, a potem je połączyć ale nie chciałbym, bo byłoby to dużo dłużej.



Offline Arek

  • Ekspert
  • *
  • Wiadomości: 3496
  • Reputacja +446/-3
  • Płeć: Mężczyzna
    • Zobacz profil
  • Gadu Gadu: 49396350
Odp: Blender nie renderuje wszystkiego
« Odpowiedź #1 dnia: 20160505, 16:57:24 »
Trudno tak cokolwiek powiedzieć nie widząc ustawień. Rozumiem, że wszystko renderowałeś z poziomu VSE i wszystkie ścieżki mają odpowiedni typ mieszania, skoro w grę wchodzi przezroczystość. Czasem, zwłaszcza jak pracuje się z kilkoma scenami, choć nie tylko i zmienia pewne elementy sceny, VSE ma problem z samoczynnym odświeżeniem zmian. Dobrą praktyką jest częste używanie przycisku Refresh Sequencer.
Najlepiej jakbyś wstawił plik. Nie muszą być w nim żadne zdjęcia (video, czy sekwencje obrazów i tak się nie zapisze w pliku), w scenach możesz wstawić cokolwiek. Chodzi o to, aby widać było ustawienia.

Offline A.S.

  • Użytkownik
  • *
  • Wiadomości: 70
  • Reputacja +0/-0
  • Płeć: Mężczyzna
    • Zobacz profil
Odp: Blender nie renderuje wszystkiego
« Odpowiedź #2 dnia: 20160505, 18:29:14 »
Sprawdziłem wszystko jeszcze raz i wygląda to tak jakby renderowała się tylko scena 1 bez całej zawartości dodanej w VSE (scn 2 i obrazków)

Dodałem dodatkowe zdjęcie nad scn. 1 i też nic.
Dodałem filmik i też nic.
W zwykłym efekcie Color to samo
Mieszanie mam chyba dobre, bo w tych obiektach z przezroczystością (np. scn. 1) użyłem alpha over.
Przycisk Refresh Sequencer też nie pomógł.

Warto jeszcze dodać że prosty podgląd jaki jest w VSE pokazuje wszystko tak jak powinno wyglądać.

Opacity mam wszędzie na 1 więc nie jest to sprawa przezroczystości.

Offline Arek

  • Ekspert
  • *
  • Wiadomości: 3496
  • Reputacja +446/-3
  • Płeć: Mężczyzna
    • Zobacz profil
  • Gadu Gadu: 49396350
Odp: Blender nie renderuje wszystkiego
« Odpowiedź #3 dnia: 20160505, 18:50:39 »
Tak masz poustawiane?

Offline A.S.

  • Użytkownik
  • *
  • Wiadomości: 70
  • Reputacja +0/-0
  • Płeć: Mężczyzna
    • Zobacz profil
Odp: Blender nie renderuje wszystkiego
« Odpowiedź #4 dnia: 20160505, 20:21:54 »
Tak. Jedyne czego nie miałem ustawione to camera overside ale już ustawiłem i nic nie pomogło.
Wygląda to mniej więcej tak:
(nie wiedziałem że można dodać załącznik)

Offline Arek

  • Ekspert
  • *
  • Wiadomości: 3496
  • Reputacja +446/-3
  • Płeć: Mężczyzna
    • Zobacz profil
  • Gadu Gadu: 49396350
Odp: Blender nie renderuje wszystkiego
« Odpowiedź #5 dnia: 20160505, 20:34:04 »
A efect transform też ustawiłeś na alpha over? Właściwie wtedy płomień można by ustawić na Repleace.
Ps. Można wstawiać załączniki, dlatego wcześniej sugerowałem, abyś wstawił plik .blend.

Offline A.S.

  • Użytkownik
  • *
  • Wiadomości: 70
  • Reputacja +0/-0
  • Płeć: Mężczyzna
    • Zobacz profil
Odp: Blender nie renderuje wszystkiego
« Odpowiedź #6 dnia: 20160506, 13:34:39 »
Tak, mógłbym wrzucić plik tylko że waży 133 MB a tu jest ograniczone do ok. 16 MB. Czy jest jakiś prosty sposób by pozbyć się z jego kopii wszystkich tekstur, bo używałem pakowania do pliku blend i po skopiowaniu go w inne miejsce nadal waży tyle samo. A używałem tekstur w dużych rozdzielczościach jak 2500x2500.

Offline Arek

  • Ekspert
  • *
  • Wiadomości: 3496
  • Reputacja +446/-3
  • Płeć: Mężczyzna
    • Zobacz profil
  • Gadu Gadu: 49396350
Odp: Blender nie renderuje wszystkiego
« Odpowiedź #7 dnia: 20160506, 14:23:34 »
Jest sposób, niżej na obrazku. Wcześniej odznacz "Automatically Pack...." jeśli masz zaznaczone, później, w następnym okienku możesz wybrać pierwszą opcję - na końcu zapisz plik.

Offline A.S.

  • Użytkownik
  • *
  • Wiadomości: 70
  • Reputacja +0/-0
  • Płeć: Mężczyzna
    • Zobacz profil
Odp: Blender nie renderuje wszystkiego
« Odpowiedź #8 dnia: 20160506, 15:29:35 »
Udało mi się usunąć z pliku tekstury (wstedy ważyło ok. 40 mb). Musiałem jeszcze usunąć wszystkie obiekty i rozmiar pliku skurczył się do 1,5 mb więc mogę go zamieścić.

Aha! i maksymalny rozmiar jednego pliku na tym forum to 4mb
16 mb to rozmiar wszystkich plików (najwięcej 10 w załączniku)

PS. Zapisanie animacji jako nowy plik albo skorzystanie z append w celu dodania scen do całkiem nowego pliku też nie pomogło.

Ja to chyba mam pecha. Zawsze mi coś nie działa!

Offline Arek

  • Ekspert
  • *
  • Wiadomości: 3496
  • Reputacja +446/-3
  • Płeć: Mężczyzna
    • Zobacz profil
  • Gadu Gadu: 49396350
Odp: Blender nie renderuje wszystkiego
« Odpowiedź #9 dnia: 20160506, 16:56:34 »
Główną przyczyną problemu jest to, że nie miałeś zaznaczonego Sequencera (VSE) w postprocessingu w pierwszej scenie, dla sceny z tłem oba (Compositing i Sequencer) mogą być odznaczone (chyba że będziesz w tej scenie kombinował coś w edytorze nodów (Compositing)). Przez to renderowało Ci po prostu tylko pierwszą scenę zamiast tego, co masz ustawione w VSE.
Jeszcze taka pomniejsza uwaga dotycząca VSE - w Twoim przypadku alpha over można ustawić tylko na końcowym punkcie. Jak masz meta pakiet a w nim jakieś zdjęcia z "alphą", dodatkowo meta pakiet potraktowany modyfikatorem "transform" - to możesz zdjęcia ustawić "repleace", meta też "repleace" a ostatni strip "transform" dopiero alpha over. Inaczej by było, jakbyś w meta pakiecie miał jakieś dodatkowe kombinacje z przezroczystością, np, jeden obraz na inny nałożony, wtedy dla ścieżki w meta pakiecie też trzeba by było ustawić "alpha over" (lub under). No ale to tylko taka dygresja, bo jak obecne Twoje ustawienia też mogą działać bez problemu.
Za chwilę podeślę plik, to zobaczysz. Chce zobaczyć, jak się wyrenderuje.
« Ostatnia zmiana: 20160506, 17:02:28 wysłana przez Arek »

Offline A.S.

  • Użytkownik
  • *
  • Wiadomości: 70
  • Reputacja +0/-0
  • Płeć: Mężczyzna
    • Zobacz profil
Odp: Blender nie renderuje wszystkiego
« Odpowiedź #10 dnia: 20160506, 18:18:40 »
Bardzo dziękuję za pomoc. Teraz działa. Zastanawia mnie tylko jedno:
 jak to się stało że ta opcja sequencer się odznaczyła?
Przecież stało się to w nocy, blender pracował, a do komputera nikt się nie dotykał.

Być może to powód żeby zacząć wierzyć w duchy lub... kosmitów.

Lub komputer nie jest tylko zwykłą maszyną. Jest żywą istotą tak jak człowiek i może robić głupie kawały swojemu właścicielowi.

Offline Arek

  • Ekspert
  • *
  • Wiadomości: 3496
  • Reputacja +446/-3
  • Płeć: Mężczyzna
    • Zobacz profil
  • Gadu Gadu: 49396350
Odp: Blender nie renderuje wszystkiego
« Odpowiedź #11 dnia: 20160506, 18:35:40 »
Jak zawsze stawiam na "zmęczenie materiału" wielogodzinną pracą, pomyłki i błędy, choć czasem można brać pod uwagę duchy, ufo :)

Offline mokasynth

  • Użytkownik
  • *
  • Wiadomości: 58
  • Reputacja +5/-0
  • Płeć: Mężczyzna
  • low art
    • Zobacz profil
    • pół całokształtu twórczości
Odp: Blender nie renderuje wszystkiego
« Odpowiedź #12 dnia: 20160602, 22:05:40 »
Mam długie przerwy pomiędzy kolejnymi pracami w Blenderze, dlatego zderzam się z irytującymi (bo podstawowymi) problemami, które dla Was będą proste do rozwiązania.
Dodałem do animacji (już złożonej wcześniej i wyrenderowanej do jednego pliku) efekt Lens Distortion i gdy renderuję, nie ma go w wynikowym renderze, a - jak widać na screenie - w podglądzie jest. Czego nie zrobiłem? (W zakładce "Post Processing" obie opcje są zaznaczone).

Offline mokasynth

  • Użytkownik
  • *
  • Wiadomości: 58
  • Reputacja +5/-0
  • Płeć: Mężczyzna
  • low art
    • Zobacz profil
    • pół całokształtu twórczości
Odp: Blender nie renderuje wszystkiego
« Odpowiedź #13 dnia: 20160602, 22:56:03 »
Solved.

Dołożyłem pustą scenę do clipu... Sorry za zawracanie dupy, ale może ktoś będzie miał podobny problem, to se zajrzy i o.

Tags:
 

© Polski Kurs Blendera, CC-BY, 2014