Forum Polskiego Kursu Blendera

Kurs Blendera dla wszystkich Polaków!

Tracking (śledzenie) > maska > kicha (maska nie porusza się z filmem)

Autor Wątek: Tracking (śledzenie) > maska > kicha (maska nie porusza się z filmem)  (Przeczytany 970 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Darek

  • Nowy użytkownik
  • *
  • Wiadomości: 25
  • Reputacja +0/-0
    • Zobacz profil
    • drukiprzelewu.pl
Dobry wieczór

Chciałbym nałożyć maskę na fragment jednego z ujęć filmu i skorygować w nim jasność, kontrast itp.
Robiłem więc tak:
1. Tworzyłem maskę w w "Movie Clip Editor".
2. W "Movie Clip Editor" ustawiałem punkty śledzenia, włączałem tracking (ctrl + T), włączałem "Solve Camera Motion" (solve error 0.19).
3. Robiłem przypisywanie punktów maski do punktów śledzenia (parenting). W oknie "Movie Clip Editor" maska całkiem nieźle śledzi ruch ujęcia.
4. W VSE dodawałem albo maskę albo pasek "Adjustment Layer", do którego dodawałem modyfikator z maską. No i maska w oknie VSE stoi. Nie przesuwa się razem z filmem.

Blender 2.78

Co robię źle, że to nie działa? Gdzieś czytałem, że to jeden ze sposobów (oprócz kluczowania).

Pozdrawiam sympatyków Blendera



« Ostatnia zmiana: 20161114, 17:21:47 wysłana przez Darek »

Offline Arek

  • Ekspert
  • *
  • Wiadomości: 3482
  • Reputacja +444/-3
  • Płeć: Mężczyzna
    • Zobacz profil
  • Gadu Gadu: 49396350
Cytuj
włączałem "Solve Camera Motion" (solve error 0.19).
Jeśli trackowałeś tylko dla maski, to to akurat nie jest konieczne, ale nie powinno przeszkadzać.

Z tego co piszesz, raczej nie powinno być problemów z ruchem maski. Jeśli przyparentowałeś maskę do tracków i w Movie Clip Editor działa bez problemu to powinno działać bez problemu w VSE w każdej konfiguracji.
Zobacz, może w MCE - w ustawieniach maski Mask Settings masz Start i End Frame dla VSE, domyślnie od 1 do 100 klatki, może to ma jakieś znaczenie dla ciebie.

Offline Darek

  • Nowy użytkownik
  • *
  • Wiadomości: 25
  • Reputacja +0/-0
    • Zobacz profil
    • drukiprzelewu.pl
Dzięki Arku. Nie wiem jak to zrobiłeś ale zaczęło działać :-)
Po otworzeniu tego wątku zająłem się edycją dalszych ujęć, a tamto problematyczne, zostawiłem na później. Teraz chciałem Ci udowodnić, że jednak nie działa i chciałem nagrać filmik, i... zaskoczyło. Normalnie jakieś czary! Zaznaczam, że robiłem refresze.



Offline Arek

  • Ekspert
  • *
  • Wiadomości: 3482
  • Reputacja +444/-3
  • Płeć: Mężczyzna
    • Zobacz profil
  • Gadu Gadu: 49396350
Te ręce potrafią lezyć na odległość :)
A tak serio może problem leżał w odświerzaniu. VSE ma to do siebie, że często nie odświerza materiału i trzeba to robić ręcznie. Najważniejsze że działa :).

Offline Darek

  • Nowy użytkownik
  • *
  • Wiadomości: 25
  • Reputacja +0/-0
    • Zobacz profil
    • drukiprzelewu.pl
Tak, działa, ale ile godzin na to straciłem... lepiej nie myśleć.

 

© Polski Kurs Blendera, CC-BY, 2014